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SPSS Statistics 17.0 (SPSS), also known as PASW Statistics, is a comprehensive system for analyzing data. SPSS
can take data from almost any type of file and use them to generate tabulated reports, charts, and plots of
distributions and trends, descriptive statistics, and complex statistical analyses.

Opening Existing Files
1. Open SPSS. Cancel out of the opening dialog box is necessary.

2. Click on the File menu. Choose Open and then Data. (You can also click the Open data document button
on the toolbar.) =

3. Browse to the folder and locate and open an SPSS data file (.sav extension).

Viewing a Data File

1. The file is displayed in the data editor of SPSS. These files are organized by cases (rows) and variables
(columns). Cases represent individual responses to a survey. Variables represent responses to each question
asked in a survey.

2. Place your cursor on a variable name (column heading) and a more descriptive variable label will display (if
one has been defined).

;.2 demo.sav [DataSet1] - PASW Statistics Data Editor

File Edit Wiew Data Transform  Analyze Grephs  Utiitiey/” Add-ons  Window  Help
EHE @ b A M AL RE 00 Y

1 age

marital | address | income | inccat | car

55
age
[ = 1 3.00 36.20
56 0 9 0 1m0 76.90
1
1

9 28.00 2.00 13.70
4 26.00 2.00 12.50

Wk =
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@

3. By default, data values are displayed. You can switch to data labels by clicking the Value Labels button %
on the toolbar or going to the View menu and choosing Value Labels.

%! demo.sav [DataSet1] - PASW Statistics Data Editor

File Edit ‘isw Data Transform  Analyze Graphs  Ufilties  Addons  Window  Help

CHE B o0 LBk s A8 B0E Bo% %

1 : ae 55

‘ age rmarital | atdress incorne | inccat car carcat

1 55| Married 12 72.00 $50 - 574 36.20 Luxury
2 86 Unrnarried 29 153.00 7o+ 76.90 Luxury
El 28 Married 9 28.00 §25- 549 13.70 Econormy
4 24 Married 4 26.00 $25 - 549 1260 Economy
] 25 Unmarried 2 2300 Under §25 11.30 Economy
B 45 Married 9 7600 §75+ 320 Luxury
7 42 Unmarried 19 4000 $26 - 543 19.80 Standard
8 35 Unmarried 15 57.00 $50 - §74 2520 Standard
9 46 Unmarried 6 2400 Under §25 12.20 Econormy
10 34 Married 0 59.00 7o+ 46.10 Luxury
11 88 Married 17 72.00 $50 - 574 35.50 Luxury
12 28 Unmarried 3 2400 Under §25 11.80 Ecanarny |
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Creating a Frequency Table

. demo.sav | DataSet1] - PASW Statistics Data Editor

B CHE B 0o BB e ) o [
1. Click on the Analyze menu. = IS

age mari CEERR=D T Car
. A _— . L AT I = Sasieet e
2. Point to Descriptive Statistics then choose Frequencies. : 5. o —— 5 o
4 24 M| Comete 1250 Eco
. R . R 5 25 Unmy Begression 1130 Eco
3. The Frequencies dialog box is displayed. 5 P > wer  wm
7 42 Unmj  Clessity ' §26 - §48 1980 staf

4. This dialog box can be resized (made wider or higher) in order to see more of or the entire list of variables.
Place your cursor on any border and simply drag.

5. Choose the variable(s) you want to analyze from the list on the left and drag them into the Variable(s) list on
the right. You can also click on the “right arrow.”

6. You can obtain additional information about a variable at any time by right-clicking the variable name in the
list.

7. Once your variable(s) are chosen, click OK to row the frequency table.

=
ariahle(s):

I= I Income category in thousands [inccat]

| Statistics.

g& Age in years [age] | |

g& Marital stetus [martal]

&’ Years at current address [address]

|
| cats. |
| Formet.. |
&’ Household income in thousands [income] -
& Price of primary vehicle [car]

ol Primary vehicle price category [carcat] —
& Level of education [ed] ‘i‘
& “ears with current employer [employ]
& Retired [retire]

ol vears with current employer [empcat]
& Job satisfaction [jobsat]

&4 Gender [gender] =

Display frequency tables

paste || Resst || cancel || Hew

8. Results are displayed in a separate “viewer” (output) window.

Income category in thousands

Cumulative
Freguency | Percent | Walid Percent Percent
Walid Under 25 1174 18.3 18.3 18.3
F25- 549 2388 T3 v 8.7
Fa0- 574 1120 17.4 17.5 732
Fra+ 1718 26.8 26.8 100.0
Tatal Ba00 100.0 100.0

9. The frequency table shows a number and percentage.

10. You can save the viewer window by clicking on the Save this document button or by going to the File menu
and choosing Save. This type of file will be saved with a .spv extension.
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Creating Charts

1. Click on the Graphs menu.

2. Choose Chart Builder.

3. Click the Gallery tab.

4. Click Bar to create a bar graph.

5. Drag the Clustered Bar icon onto the canvas to create this type of graph.

6. To determine the people who have a wireless service that also own a PDA, two variables will need to be
added to the canvas: Wireless service and Owns PDA.

7. Both variables need to be set to Ordinal measurement in order to create a graph. Right-click Wireless service
and then choose Nominal as the measurement level.

8. Drag Wireless service to the x axis.
9. Right-click Owns PDA and choose Nominal as the measurement level.

10. Drag Owns PDA to the “cluster on x” area in the upper right corner.

i Chart Builder x|

“ariables: Chart preview nses example data

& woice mail [voice] |~ Cluster on X: set color
& Paging service [pag...
& nternet firternet] | ||| oo
& caller D [callid]

& Call waiting [callwat]
& vens TV [owenty]
f Cwvns WOR [ownver] [
& Owens stereafCOpll. |
&3 vvns PDA [ovenpca] -
& owns computer [a...
ﬁ Creeniz fax maching I;

Count

e | fes

[ ves

3 Wireless senvice

Gallery ] Basic Elements | GroupsPoirt 0 | Title=/Footnotes |
Choose from: Element
Favorites Properties..
Bar

e HI_I
area

PiePalar
ScatterDot ‘ II o) Q % ¢ ¢
Histogram

High-Lowe q’ ¢ ¢

Boxplot
Dual &xes

Ok ” Paste ” Reset H Cancel ” Help ]
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11. Click OK to create the chart.

Cwns PDA

W
4,000 W ves

3,000

Count

2,000

1,000

Wireless service

12. You can edit charts by double-clicking them in the contents pane of the viewer window.

13. You can also copy and paste your results into other applications.

Opening Excel Files

In order to easily open an Excel spreadsheet, the first row of the spreadsheet should be a heading row. Delete any
blank rows, extra text, fancy formatting, etc.

1. Click on the File menu. Choose Open and then Data. (You can also click the Open data document button
on the toolbar.) =

2. Inthe Files of type drop-down box, choose All Files.
3. Browse to the folder and locate and open an Excel file (.xls extension).

4. Inthe Opening Excel Data Source dialog box, make sure Read variable names from the first row of data is
checked. You can also specify a range or worksheet to use, if wanted.

L3t Opening Excel Data Source x
CProgram Fil PSSInc istics1 7 ples'Englishidemo xls

head variahle names from the first rowe of data)

Wiorksheet: [ demo [41:486401] |

Range: | |

adimum wicth for string columns: 32TET

[ox [ corcs J[_rep_|
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5. Click OK.

6. The data should now appear in the data editor with the column headings used as the new variable names.
Variable names cannot contain spaces. Therefore, spaces from the original headings will be removed.

i *Untitled2 [DataSet2] - PASW Statistics Data Editor

File  Edit “iew Data Transform Analyze Graphs  Utiities  Add-ons  Window  HNp

FHAE T 60 LEEk & A4 E6HE B W

1 Adge 25

Age Maritalstatus Address Incorme IncomeCategory Carprice Carpricecategary

1 55 1 12 7200 3.00 37.00 3.00
2 56 0 29 153.00 4.00 76.00 3.00
3 23 1 9 28.00 200 13.80 1.00
4 24 1 4 26.00 200 13.00 1.00
5 25 1 2 23.00 1.00 11.30 1.00
<1 45 0 9 76.00 4.00 37.30 3.00

Creating a New Data File
The data editor displays the contents of the data file. There are two views in the data editor:

o Data View, where columns represent variables and rows represent cases
e Variable View, where each row is a variable and each column an attribute associated with a variable

Before data can be entered, the variables you will be using must be defined.
Numeric Variables and Data
1. Click the Variable View tab at the bottom of the data editor window.
2. Three variables will be used: age, marital status, and income.
3. Inthe first row of the first column, type age.
In the second row of the first column, type marital.

In the third row of the first column, type income.

4. New variables are automatically given a Numeric data type (see second column).

&2 *Untitled1 [DataSet0] - PASW Statistics Data Editor

File Edit “iew Data Transform  Analyze Graphs  Lilties  Add-ons

CHA E 60 Bk A I8 268 B

MName | Type | Width | Decimals | La
age Murneric g 2
rnatital Murmeric g 2
income Mumeric g 2

o | = L | —

Karen Boland, M.S. « September 2009 Marywood University



Side 6 of 9

ek

Use SPSS

‘H‘DW —‘[‘D ® ® ® . B

t

5. To enter data, click the Data View tab.

6. Notice that the names you entered in Variable View are now the headings for the first three columns in Data
View.

7. Begin entering data for age, marital and income across the rows (use the Tab key:

55 1 72000
53 0 153000

8. The age and marital columns display decimal points. You do not want decimal points.

5 *Untitled1 [DataSet0] - PASW Statistics Data Editor

File Edit ‘“iew Data  Transform  Analyze  Graphs  Uilties
EHE t &0 mEE A HE EERE
3 e
age marital | income | var

1 55.00 1.00 72000.00

2 53.00 .00 153000.00

s |

4 |

9. Click the Variable View tab. In the Decimals column of the age and marital rows, type 0 to hide the
decimals.

10. Switch back to Data View. The decimals are gone.

vai *Untitledl [DataSetd] - PASW Statistics Data Editor

File Ecit “ew Data Transform  Analyze  Graphs  Lhilties &
EHE I & xEE A A EEEH
3 age
age matital | income | var

1 a4 1 72000.00

2 a3 0 153000.00

3 |

4 |

String Variables and Data

1. To add another variable which will consist of text (string), click the Variable View tab.

2. In the fourth row and first column, type sex.

3. Click into the Type cell next to your entry.

4. Select String to specify the variable type. You can also extend the default length (8) if you wish.

5. Click OK.
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Changing Variable Types x|

() Mumetic st =
1. Click into the Type column for a variable (like income). O gomma ::::w B

(@]:: $#,###
2. Select another type (like Dollar). () Scientific notation |34 44 2

() Date
3. Select a format by clicking on it. @ Dellr i,

() Custom currency Wicith:
4. C"Ck OK () String Decimal Blaces: l:l

| Ok _” Cancel || Help |

Adding Variable Labels

Labels provide descriptions of variables. They are longer versions of the variable names. These labels are used in
your output to identify the different variables.

1. Click the Variable View tab.

2. Inthe Label column of the age row, type Respondent’s Age.
In the Label column of the marital row, type Marital Status.
In the Label column of the income row, type Household Income.
In the Label column of the sex row, type Gender.

%2 *Untitled1 [DataSet0] - PASW Statistics Data Editor

File  Edit Miew Data Transform  Analyze Graphs  Uilties Add-ons Winplow  Help

FHE B 00 Bk A s EaE BoY %

MName | Type | Width | Decimals| Lahel “alues
1 age MNumeric g 0 Respondent's Age Mane
2 marital MNumeric 8 0 Marital Status Maone
3 incarne MNumeric 8 2 Househald Income Mane
4 sex String 8 0 Gender Mane
5 | |

Adding Value Labels

Value labels provide a way to interpret the numbers assigned to some of your variables.

1. Click the Values cell for the marital row (a Numeric E”"” .

variable). o —

) alue: | Spelling... |
Label: |parried|

2. Type 0inthe Value field. Type Single in the Label | E— |

field. Click Add. [ aw
3. Type 1in the Value field. Type Married in the Value

field. Click Add.

0K | | Cancel | ‘ Help

4. Click OK.
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5. Click the Values cell for the sex row (a String el X
Variable) . Value Labels
6. Type F inthe Value field. Type Female in the Label ez | |
field. Click Add. F = "Femals"
M = "hale"
7. Type M in the Value field. Type Male in the Label
field. Click Add.
8' CIICk OK QK || Cancel || Help

Using Value Labels for Data Entry

1. Click the Data View tab.

2. Click the Value Labels button on the toolbar to display labels (if they aren’t already displayed).
3. Select the first cell that represents sex.

4. Choose Male from the drop-down list.

5. In the second row, select the cell for sex.

6. Choose Female from the drop-down list.

Missing Data

Missing data may result in your analysis producing inaccurate results. It should be coded.
1. Click the Variable View tab.

2. Click the Missing cell in the age row.

3. Inthe Missing Values dialog box, click into Discrete missing values and type 999.

e

Click OK.

Lai Missing Values

() Mo missing values
'3:5‘:1' Dizcrete missing values
pas I I

'3::1' Range plus one optionsl discrete mizsing value

| OH _J | Cancel | | Help
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5. Click the Values cell in the age row.

6. Type 999 in the Value field. Type No Response in the Label field. Click Add.

-5f Value Labels x

Value Labels

Lahel: |Nn Responze |

(e ]

ok || cancet || Hew

7. Click OK.

8. Click the Missing cell in the sex row.

9. Inthe Missing Values dialog box, click into Discrete missing values and type NR.
10. Click OK.

11. Click the Values cell in the sex row (you should already have M and F entered).
12. Type NR in the Value field. Type No Response in the Label field. Click Add.

13. Click OK.

Saving a Data File
1. Click the Save this document button on the toolbar or click on the File menu and choose Save.

2. The file will be saved with a .sav extension.
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